Sep 04

COMPLETED: PHP Upgrade – cPanel Services

Due to major security issues with the currently deployed version of the PHP runtime, and the appearance of 0-day exploits for these issues; we have been forced to upgrade PHP to the latest 5.4 branch on all cPanel services.

For most up-to-date pre-packaged applications, this should have no effect.  However, custom sites, modules for pre-packaged software and templates may have been relying on older syntax or features that are now no longer allowed.

If you have used the Softaculous 1-click-installer, please make sure you update your installations as soon as possible.  Otherwise you may need to make adjustments or changes to the code of your site or obtain upgrades from 3rd party vendors.

We apologise that this announcement could not have been made sooner, however the nature and urgency of the issues prevented that.